Bill Pay Outage for Personal Online

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted May 18, 2025 - 07:57 EDT

Investigating

We are currently experiencing an issue with the Bill Payment feature in our Personal Online banking service, including our mobile app. Users may encounter an error message stating that the feature is unavailable or that the page cannot be accessed. We are working diligently to restore service and apologize for any inconvenience this may cause.
Posted May 18, 2025 - 07:18 EDT
This incident affected: Personal Services (Bill Pay Services).