Personal and Business Online Banking Apps

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 19:53 EDT

Investigating

We are currently experiencing an issue with our Personal and Business mobile apps. Users may encounter an error message stating that the feature is unavailable or that your session has timed out. We are working diligently to restore service and apologize for any inconvenience this may cause. Our Personal and Business Online banking services, accessible from our website, remain fully operational for your banking needs.
Posted Mar 25, 2025 - 19:08 EDT
This incident affected: Business Services (Business Mobile App) and Personal Services (Personal Mobile App).