Personal Mobile Banking - Intermittent Accesss
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jul 10, 2024 - 10:23 EDT
Investigating
We are currently researching an issue that is resulting in intermittent availability for users attempting to access our Personal Mobile Banking app. While we work to restore service, users can continue to access their account information through Personal Online from our website at www.hinghamsavings.com.
Posted Jul 10, 2024 - 09:19 EDT
This incident affected: Personal Services (Personal Mobile App).