eStatements
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Aug 12, 2020 - 13:02 EDT
Identified
We are currently experiencing intermittent issues when retrieving eStatements in both retail and business online banking. A solution has been identified and will be implemented on July 29th, 2020. If you need immediate assistance please contact us at 781-749-2200.
Posted Jul 20, 2020 - 16:26 EDT
This incident affected: Personal Services (Electronic Statements).