External Transfers for Personal Online and Mobile Banking

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Dec 16, 2024 - 12:01 EST

Investigating

We are currently investigating intermittent service interruptions with our External Transfer service for Personal Online and Mobile banking. Some users may experience errors when initiating payments. We are working to restore services as quickly as possible and apologize for the inconvenience
Posted Dec 16, 2024 - 11:51 EST
This incident affected: Personal Services (Account Transfers).