TransferNow for Retail Online Intermittently Unavailable
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 11:31 EDT
Update
We are continuing to investigate this intermittent disruption.
Posted Jul 15, 2022 - 11:11 EDT
Investigating
We are currently investigating an issue with Transfernow for Retail Online where users may be intermittently unable to access features.
Posted Jul 14, 2022 - 13:33 EDT
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App).