Personal and Business Online Banking and Mobile Apps

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jan 01, 2026 - 10:59 EST

Update

We continue to work with our partners to restore access to recent transaction history in our Personal and Business Online banking services, including our mobile apps. We appreciate your patience as we work to restore service and apologize for any inconvenience this issue has caused,
Posted Jan 01, 2026 - 09:53 EST

Update

While we continue to work with our partners, we are seeing improvements in the functionality of our digital tools. Users are now able to access Personal Online and balances have been restored for checking accounts when accessing from the home pages in Personal or Business Online banking as well as our mobile apps. We continue to work to restore recent transaction history and running balance information in our Personal and Business Online banking services, including our mobile apps. Thank you for your patience while we work to resolve this issue as quickly as possible
Posted Jan 01, 2026 - 08:39 EST

Investigating

We are aware of an issue impacting our Personal and Business Online banking services, including our mobile apps. Users attempting to log in to Personal Online may receive an error message indicating the service is experiencing technical difficulties. Additionally, users may not be able to access transaction and balance information for checking accounts when logged in to Business Online, or our mobile apps. We are working to restore service as quickly as possible and apologize for the inconvenience.
Posted Jan 01, 2026 - 07:33 EST
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App) and Business Services (Business Online Banking, Business Mobile App).