We are continuing to monitor for any further issues.
Posted Sep 19, 2026 - 13:18 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 19, 2026 - 13:09 EDT
Monitoring
Online Banking is currently undergoing scheduled migration activities ahead of our Monday, September 21st platform launch. We are aware of an issue impacting mobile app logins and account visibility.
WHY YOUR APP LOOKS DIFFERENT TODAY: If your mobile device has automatic app updates enabled, your Hingham Mobile App was automatically updated to our new online banking platform version ahead of schedule. Because data migration is currently underway, logins on the updated mobile app remain restricted for retail clients until Monday, September 21st at 9:00 AM ET.
WHAT THIS MEANS FOR YOU TODAY:
• Error Messages: If you attempt to log in using the newly updated mobile app today, you may see error messages such as "Incorrect Password" or "Account Locked." Please be assured your credentials are safe, your accounts are secure, and your account is NOT locked. This is an automated temporary restriction while backend data migration completes.
• Account Visibility Delays: Users who were previously able to log in may also experience temporary account display delays while system data finishes syncing across our platform.
• Web Browser Access (Inquiry-Only Mode): Personal banking clients wishing to view account balances and transaction history today can do so by opening a web browser on their mobile phone or desktop at hinghamsavings.com and logging in there.
• Cards & ATMs: Physical debit cards, ATMs, and external direct debits/auto-pays continue to run normally and remain fully operational.
Our technical and operations teams are actively monitoring system deployment. Full access to the new mobile platform will officially open Monday morning at 9:00 AM ET.
Posted Sep 19, 2026 - 13:01 EDT
Update
Online Banking is currently undergoing scheduled migration activities ahead of our Monday, September 21st platform launch. We are aware of an issue impacting mobile app logins.
WHY YOUR APP LOOKS DIFFERENT TODAY: If your mobile device has automatic app updates enabled, your Hingham Mobile App was automatically updated to our new online banking platform version ahead of schedule. Because data migration is currently underway, logins on the updated mobile app remain restricted for retail clients until Monday, September 21st at 9:00 AM ET.
WHAT THIS MEANS FOR YOU TODAY:
• Error Messages: If you attempt to log in using the newly updated mobile app today, you may see error messages such as "Incorrect Password" or "Account Locked." Please be assured your credentials are safe and your account is NOT locked; this is simply an automated temporary restriction while system migration completes. • Web Browser Access (Inquiry-Only Mode): Personal banking clients wishing to view account balances and history today can do so by opening a web browser on their mobile phone or desktop at hinghamsavings.com and logging in there. • Cards & ATMs: Physical debit cards, ATMs, and external direct debits/auto-pays remain fully operational.
Our technical and operations teams are actively monitoring system deployment. Full access to the new mobile platform will officially open Monday morning.
Posted Sep 19, 2026 - 11:37 EDT
Identified
We are actively performing scheduled migration activities ahead of our Monday, September 21st digital platform launch.
The primary Mobile App in the Apple App Store and Google Play Store has automatically updated to our new digital banking platform. Because data migration is currently underway, logins on the updated mobile app remain restricted for retail clients until Monday, September 21st at 9:00 AM ET.
WHAT THIS MEANS FOR YOU TODAY:
• Error Messages: If you attempt to log in using the updated mobile app today, you may see error messages such as "Incorrect Password" or "Account Locked." Your credentials are safe, and your account is not locked; this is a temporary restriction while system migration completes. • Web Browser Access (Inquiry-Only Mode): Personal banking clients wishing to view balances and account history today can log in via a desktop or mobile web browser at hinghamsavings.com using their existing credentials. • Cards & ATMs: Physical debit cards, ATMs, and external direct debits/auto-pays remain fully operational.
Our engineering and operations teams are actively monitoring system deployment. Access to the new mobile platform will officially open Monday morning.
Posted Sep 19, 2026 - 10:25 EDT
This incident affects: Personal Services (Personal Online Banking, Personal Mobile App, Bill Pay Services, Electronic Statements, Account Transfers) and Business Services (Business Online Banking, Business Mobile App, Desktop Remote Deposit Capture, ACH/Wire Transfer Services, Bill Pay, Electronic Statements, ACH Transaction Posting).