Wire Processing Delays

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 13:51 EST

Investigating

We are currently experiencing processing delays for incoming and outgoing domestic wire transfers. We are working to restore normal service levels as quickly as possible. We apologize for the inconvenience. To check the status of an outgoing wire, please contact us at 781.749.2200.
Posted Feb 17, 2026 - 12:56 EST
This incident affected: Business Services (ACH/Wire Transfer Services).