Corporate Office Phone System

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Oct 08, 2024 - 16:14 EDT

Investigating

We are currently experiencing an outage impacting our main corporate phone system. We are working as quickly as possible to restore service and apologize for the inconvenience. To reach our Customer Experience Team, please email us at cs@hinghamsaving.com.
Posted Oct 08, 2024 - 15:28 EDT
This incident affected: Phone Lines.