Personal and Business Online Payment Posting Delays
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Dec 29, 2023 - 12:25 EST
Update
We are continuing to investigate this issue and apologize for the inconvenience.
Posted Dec 29, 2023 - 10:46 EST
Investigating
We are aware of an issue that has caused a delay in the posting of electronic payments scheduled for today, December 29th through our Personal and Business Online Bill Payment service. We are working to post the payments as quickly as possible and apologize for the inconvenience. Payments sent in check form are not impacted by this issue and users can continue to access and schedule payments as needed.
Posted Dec 29, 2023 - 09:58 EST
This incident affected: Personal Services (Bill Pay Services) and Business Services (Bill Pay).