Personal Online Banking Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 08:08 EST

Investigating

We are currently experiencing an issue impacting our Personal Online banking service. Users attempting to log into Personal Online from our website may receive an error message indicating the service is unavailable. We are working with our partners to restore service as quickly as possible and apologize for any inconvenience this issue has caused. While we work to restore service, users can access account information using our Personal Mobile Banking app which is remain fully operational and available for use.
Posted Jan 21, 2026 - 07:32 EST
This incident affected: Personal Services (Personal Online Banking).