Business Online
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Oct 31, 2022 - 18:20 EDT
Investigating
We are currently experiencing an outage with our Business Online Banking services. Our mobile app remains fully operational for your banking needs. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Oct 31, 2022 - 14:46 EDT
This incident affected: Business Services (Business Online Banking).