Hingham Savings Debit Cards
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jan 02, 2023 - 19:10 EST
Update
We continue to work to restore service as quickly as possible and apologize for the inconvenience.
Posted Jan 02, 2023 - 17:21 EST
Update
We continue to work to restore service as quickly as possible and apologize for the inconvenience.
Posted Jan 02, 2023 - 10:26 EST
Investigating
We are experiencing issues impacting our automated phone systems for debit card activation, reporting cards lost or stolen and some features through the My Cards option in our Personal Mobile Banking App. We are working to restore service as quickly as possible and apologize for any inconvenience these issues have caused.
Posted Jan 02, 2023 - 09:06 EST
This incident affected: Personal Services (HIFS Mastercard Debit Cards, HIFS My Card App).