Phone System

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted May 21, 2025 - 16:53 EDT

Investigating

We're currently experiencing an outage with our phone system. We are working quickly to restore service and apologize for the inconvenience. To reach our Customer Experience Team, please use the chat functionality on our homepage or email us at cs@hinghamsaving.com.
Posted May 21, 2025 - 10:49 EDT
This incident affected: Phone Lines.