Personal Mobile Banking for iPhone Users
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jun 25, 2024 - 13:37 EDT
Update
We are continuing to investigate this issue.
Posted Jun 25, 2024 - 06:54 EDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2024 - 21:40 EDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2024 - 20:37 EDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2024 - 19:29 EDT
Investigating
We are are of an issue impacting our Personal Mobile Banking app for some iPhone users. Users may receive an error message indicating we we unable to validate their information when launching the app. We are working with our partners to restore access as quickly as possible and apologize for the inconvenience. While we work to restore service users can continue to access their account information through Personal Online from our website at www.hinghamsavings.com.
Posted Jun 24, 2024 - 19:27 EDT
This incident affected: Personal Services (Personal Mobile App).