Debit Card Transaction Processing Interruption
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jun 17, 2024 - 09:45 EDT
Investigating
We are aware of an issue impacting Hingham Savings Debit Cards that may cause some transactions to be declined in error and spending limits to be reduced to $500 for purchases and $200 for withdrawals at an ATM. We are working to restore service as quickly as possible and apologize for the inconvenience.
Posted Jun 17, 2024 - 08:41 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards).