Digital Accounts
Incident Report for Hingham Institution for Savings
Resolved
A fix has been implemented and this issue has been resolved.
Posted May 21, 2020 - 16:54 EDT
Investigating
We are currently experiencing a technical issue in our platform that supports digital account opening. Customers may not immediately receive an account number, although the account has been opened on our system. We are working to diagnose the issue and implement a fix.
Posted May 21, 2020 - 15:08 EDT
This incident affected: Personal Services (Digital Account Opening).