Personal and Business Online - Email Notifications Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 16:53 EDT

Investigating

We are working to resolve an issue that is preventing email notifications from generating for our Personal and Business Online banking platforms. Personal and Business Online clients attempting to use the forgotten password feature, who have changed their password or email addresses in Personal or Business Online may not receive the temporary password or the email to confirm the requested changes. In addition, Business Online clients who request a one-time-passcode after entering their password, may not receive the code via email as expected.

Our partners are working to restore service as quickly as possible. For assistance with account information, please contact us at 781-749-2200 for assistance. Our Client Experience Team is here to help.
Posted Jul 14, 2025 - 16:21 EDT
This incident affected: Personal Services (Personal Online Banking) and Business Services (Business Online Banking).