Wire Transfer Processing

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 11:21 EDT

Update

We are seeing significant improvements to the processing times for both incoming and outgoing domestic wires, with wires processing as expected. We are, however still experiencing delays for outgoing foreign wires. We understand this can be frustrating and we are actively working with our partners to restore service as quickly a possible. We appreciate your continues patience and understanding
Posted Jul 16, 2025 - 08:58 EDT

Investigating

We are currently experiencing processing delays for both incoming and outgoing wire transfers. While we continue to process incoming and outgoing wires, processing times are extended and may take longer than normal. We are working to restore service as quickly as possible and apologize for any inconvenience this issue as caused. To inquire question about the status of an incoming or outgoing wire, please contact us at 781.749.2200.
Posted Jul 15, 2025 - 18:16 EDT
This incident affected: Business Services (ACH/Wire Transfer Services).