Debit Card - Intermittent Access Issues for Activation and PIN Selecton

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 13:48 EDT

Investigating

We are currently experiencing an issue that may cause some users to be unable to select their PIN or activate their debit card when calling our card activation line. We are working to restore service as quickly as possible and apologize for the inconvenience. Users with access to our Personal Mobile App can select their PIN and activate their cards using the Cards feature within the app.
Posted Jul 14, 2025 - 12:25 EDT
This incident affected: Personal Services (HIFS My Card App).