Retail Online Bill Pay Enrollment
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jun 08, 2022 - 17:09 EDT
Investigating
We are currently investigating an issue with some users being unable to complete enrollment in CheckFree Billpay through Retail Online. We are working to restore service as quickly as possible.
Posted Jun 08, 2022 - 15:58 EDT
This incident affected: Personal Services (Personal Online Banking, Bill Pay Services).