Personal and Business Mobile Deposits
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 11:54 EDT
Investigating
We are aware of an issue that is preventing some mobile deposits from being reflected in the account transaction history. We are working to resolve this issue as quickly as possible and apologize for the inconvenience.
Posted Jul 19, 2021 - 11:24 EDT
This incident affected: Business Services (Business Mobile App) and Personal Services (Personal Mobile App).