Phone Outage
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 16:24 EDT
Update
We are continuing to investigate this issue.
Posted Jul 13, 2021 - 10:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 13, 2021 - 09:47 EDT
Investigating
We are currently experiencing intermittent phone issues. If you need assistance, please email us at cs@hinghamsavings.com or use the chat feature on our website. Thank you for your patience as we work to resolve those phone lines that are impacted.
Posted Jul 13, 2021 - 09:46 EDT
This incident affected: Phone Lines.